Sagemcom F@ST 2804 и OpenWRT

Sagemcom F@ST 2804 и OpenWRT

Обновленная статья о том, как прошить роутер Sagemcom F@st 2804 в OpenWRT или восстановить «кирпич».

Аттракцион невиданной щедрости от компании Ростелеком — китайский роутер Sagemcom F@ST 2804 v. 5 в нагрузку к контракту.  ту же модель роутера предлагаелось получить у многих федеральных и региональных операторов домашнего интернета. Даём ему вторую жизнь.

Внимание!

После установки OpenWRT не будет работать ADSL порт.

Прошивка F@st 2804

Вскрытие показало, внутри:

  • Broadcom BCM63281KFBG;
  • 2 USB порта;
  • RJ-25 для телефонного кабеля ADSL модема;
  • 4 LAN порта.

Аппаратная конфигурация полностью идентична роутеру Sagemcom F@ST 2704, к которому существует сборка OpenWRT.

Существует OpenWRT 15.05 с предустановленным руссифицированным графическим интерфейсом LuCi. Настоятельно рекомендую использовать именно эту сборку, так как она содержит более новые ядро и пакеты, исправлен ряд неприятных ошибок и проблем с Wi-Fi.

Дальше всё как в тумане:

  • Скачиваем бинарный файл прошивки;
  • Заходим в стандартный веб-интерфейс роутера (по-умолчанию 192.168.1.1 логин и пароль: admin);
  • Переходим в раздел обновления прошивки и выбираем бинарный файл OpenWRT.

Настройка

Обновить старую прошивку на OpenWRT можно через Wi-Fi, но для настройки необходим патч-корд. После того, как прошивка будет установлена, Wi-Fi пропадёт.

В рекомендуемой к установке сборке появился графический интерфейс, что делает её использование приятнее.

Подключиться к прошитому роутеру для настройки можно следующим образом:

  • Необходимо подключить кабелем сетевой порт компьютера и роутер (не подключайте в 4 порт);
  • Настроить сетевое подключение:
    • IP адрес 192.168.1.2
    • Маска подсети: 255.255.255.0
    • Шлюз: 192.168.1.1
  • Перейти в браузере по адресу 192.168.1.1

Должен открыться графический интерфейс LuCi.

  • Логин: root
  • Пароль: qwerty12345

Рекомендую сменить пароль пользователя root на более сложный.

Далее можно сконигурировать роутер через удобный веб-интерфейс.

Настройка по SSH

OpenWRT по-умолчанию включает в себя только текстовый редактор Vi.

Для редактирования настроек потребуется всего несколько команд:

  • :w — записать изменения в файл (сохранить);
  • :q! — выйти, не сохраняя текущие изменения;
  • :wq! — выйти, сохранив изменения в файле.

Для перехода между режимами редактирования и ввода команд, используется клавиша ESC.

Открываем /etc/config/network и копируем в него следующий конфиг, поправив значения под своего провайдера:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0.1'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'eth0'
option vlan '1'
option vid '1'
option ports '1 2 3 8t'
config switch_vlan
option device 'eth0'
option vlan '2'
option vid '2'
option ports '0 8t'
config interface 'wan'
option ifname 'eth0.2'
option proto 'static'
option ipaddr '10.XXX.XXX.151' #Ваш IP-адрес
option netmask '255.255.252.0' #Маска подсети, выделенная провайдером
option gateway '10.214.31.254' #Шлюз
list dns '83.XXX.XX.1' # Здесь прописать пару DNS
list dns '83.XXX.XX.2'

ВАЖНО!
По возможности не используйте сторонние DNS сервера от публичных компаний, даже таких именитых как Яндекс или Google. Используйте DNS предоставленные провайдером. Не вдаваясь в конкретные причины, могу сказать, что это избавит от многих проблем и аномалий.

Для настройки Wi-Fi редактируем /etc/config/wireless. Мой конфиг имеет следующее содержание:

config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11g
option path 'pci0000:00/0000:00:00.0/0000:01:00.0/bcma0:1'
option htmode
config wifi-iface
option device radio0
option network lan
option mode ap
option ssid WIFI-Name # Название Wi-Fi сети
option encryption mixed-psk+ccmp # Тип шифрования
option key Password!
option macaddr 7c:03:XX:XX:XX:XX # Здесь вписать свой MAC-адрес

MAC-адрес можно посмотреть в наклейке на корпусе роутера.

Восстановление роутера F@st 2804

Изначально проводил эксперименты с OpenWRT 14.07, но во время обновления пакетов, роутер закирпичился. Невозможно было подключиться, ни через веб-интерфейс ни через SSH. Роутер мигал индикатором питания не подавая других признаков жизни.

Действия:

  1. Скачиваем стоковую прошивку от производителя;
    • Не обязательно скачивать прошивку провайдера, можно использовать любую другую под эту модель. Использовал прошивку Ростелеком под 2804 V.7 (необходимо разархивировать) с сайта Sagemcom.
  2. Подключаем роутер кабелем, как описано в разделе Настройка;
  3. На задней стороне роутера выключаем кнопку питания;
  4. Зажимаем кнопку Reset и включаем кнопку питания, удерживая Reset около минуты, пока индикатор питания на передней панели не загорится красным цветом.
  5. Переходим в браузере по адресу 192.168.1.1 и если всё было сделано правильно, то должно появиться меню восстановления прошивки.
  6. Нажимаем Choose File и выбираем файл стоковой прошивки, затем Update Software;
  7. Ждем пару минут, пока роутер прошьётся и перезагрузиться.

После этого роутер можно прошить стандартным способом, как описано выше в пунке Прошивка F@st 2804.

Заключение

В поиске на Avito можно найти такой роутер по цене 300 руб. Внешне они сильно друг от друга отличаются, так как многие операторы связи заказывали его в брендированных корпусах. Это не должно смущать, внутри они все одинаковы.

После установки новой прошивки, можно использовать другие многочисленные возможности OpenWRT о которых расскажу в отдельной статье.

Роутер Sagemcom F@ST 2804 имеет приличную начинку, по отношению к другим устройствам, предоставляемым операторами вместе с контрактом оператора домашнего интернета.

  • Nick

    Опишите как настроить 3g модем, создать ppoe соединение…?

  • Егоров Димма

    Ссылка на скачивание битая, можно найти прошивку для f@st 1744 v2 с интерфейсом LuCi ?

    • Сссылку поправил. Собраной прошивки такой нет.